The Sky Ahead: iOS 4 Required for ForeFlight 4

We’ve been working hard in the ForeFlight labs on some exciting new features. The results are fantastic, and we can’t wait to share them in the coming weeks and months!

The sky ahead requires breaking ties with older iOS systems and hardware so that we can push forward.  The next major version of ForeFlight – version 4 – will require iOS 4 or greater. This means that ForeFlight 4 will only work on iPhone 3GS, iPhone 4, all versions of iPads (iPad 1 and iPad 2), and the last two iPod touch models (3rd and 4th generation) – as well as any new iPhone/iPad/iPod touch models in the future.

By making iOS 4 the baseline, we get access to technologies that take advantage of multi-core processor support, mathematical acceleration routines, superior graphics technologies, and other goodies under the hood.  This boils down to a faster, more feature-packed ForeFlight. We’ve been testing the improvements for months, and the app really flies!

If you’re running one of the supported devices but still have iOS 3 installed, updating to iOS 4 is free and easy to do from iTunes. If you’re running an older device that is not supported, like an iPhone 3G or older iPod touch, you’ll be able to keep running ForeFlight 3 but you won’t be able to update to the new version.

ForeFlight v4 will be a free update in the App Store for existing subscribers.  We’ll be announcing more about the new features in the coming weeks – stay tuned!