iOS 5.0 and ForeFlight Mobile 2.4

ForeFlight Mobile 2.4 is not compatible with iOS 5.0 or greater. Customers that wish to continue using ForeFlight Mobile 2.4 will need to use iOS 4.3 or earlier. ForeFlight Mobile 4, however, is compatible with iOS 5 but requires the purchase of a subscription.