Next ForeFlight Release to Require Apple iOS 9.2 or Later

The next ForeFlight release will require Apple iOS 9.2 or later. By making iOS 9.2 the minimum iOS version supported, we can deliver advanced features, smaller app download sizes, faster performance, and improved energy efficiency. In addition, you don’t have to worry about losing support for your older devices – all the devices that support iOS 8.2 (the current minimum iOS requirement for ForeFlight) are all capable of updating to iOS 9.2.

We recommend you update as soon as practical. This support article on Apple’s website describes how to update your iOS device wirelessly or using iTunes if you want to get ahead of the release.

As always, if you have any questions, we are on frequency seven days a week at team@foreflight.com.