Apple iOS 12.0.1 and ForeFlight

UPDATE October 11, 2018: ForeFlight is ready for iOS 12.0.1 on all supported devices with a newly-released app version (10.4.1). We recommend that all customers first update to the new ForeFlight version, available now in the Apple App Store, and then update to the new iOS version if you haven’t already.

You can check what version of ForeFlight you have by opening the app and going to More > About, then looking at the top of the page to see the version number. Follow this link to learn how you can check which Apple iOS version you are currently running, and follow this link to learn how you can update your iOS version.

UPDATE September 28, 2018: We have discovered a compatibility issue between ForeFlight and iOS 12 affecting the iPad Mini 4, iPad Air 2, iPhone 6, and older devices. These devices may experience persistent app crashes while running ForeFlight on iOS 12.

We have notified Apple of this issue and our team is working on finding and implementing a fix, but for now we recommend that all customers “hold short” on updating to iOS 12 on any iPad Minis, iPad Airs, iPhone 6, and older devices used in flight. We will notify you as soon as a fix is available.

Newer devices are not impacted by this issue and are clear to update to iOS 12. These include any iPad Pro, iPad 5th generation and above, and iPhone 6S and above.

If you’re not sure which iPad or iPhone model you have, visit this page to check your iPad model and this page to check your iPhone model. Follow this link to learn how you can check which Apple iOS version you are currently running. Please also stay tuned to our Facebook page or Twitter feed for updates.

ORIGINAL POST September 17, 2018: We are performing compatibility testing between ForeFlight and the newly released iOS 12 to ensure that everything is working smoothly. We will update this post with an “all-clear” when testing is completed. Please also stay tuned to our Facebook page or Twitter feed for updates.

Follow this link to learn how you can check which Apple iOS version you are currently running.